# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[(?<group>.*)(?<!:children)\]"
test_str = ("[man-aged-sql:children]\n"
"ManagedMSSQLDBMS2016DBAMode\n"
"ManagedMSSQLServer2016\n"
"ManagedMSSQLServer2017\n\n"
"[all_managed:children]\n"
"server01\n"
"server02\n\n"
"[notmanaged]\n"
"server04\n"
"server05\n\n"
"[ManagedMSSQLServer2016]\n"
"Server4\n"
"Server5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.