#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(?<group>.*)(?<!:children)\]"
Local $sString = "[man-aged-sql:children]" & @CRLF & _
"ManagedMSSQLDBMS2016DBAMode" & @CRLF & _
"ManagedMSSQLServer2016" & @CRLF & _
"ManagedMSSQLServer2017" & @CRLF & _
"" & @CRLF & _
"[all_managed:children]" & @CRLF & _
"server01" & @CRLF & _
"server02" & @CRLF & _
"" & @CRLF & _
"[notmanaged]" & @CRLF & _
"server04" & @CRLF & _
"server05" & @CRLF & _
"" & @CRLF & _
"[ManagedMSSQLServer2016]" & @CRLF & _
"Server4" & @CRLF & _
"Server5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")