using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(?<group>.*)(?<!:children)\]";
string input = @"[man-aged-sql:children]
ManagedMSSQLDBMS2016DBAMode
ManagedMSSQLServer2016
ManagedMSSQLServer2017
[all_managed:children]
server01
server02
[notmanaged]
server04
server05
[ManagedMSSQLServer2016]
Server4
Server5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}