import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(?<group>.*)(?<!:children)\\]";
final String string = "[man-aged-sql:children]\n"
+ "ManagedMSSQLDBMS2016DBAMode\n"
+ "ManagedMSSQLServer2016\n"
+ "ManagedMSSQLServer2017\n\n"
+ "[all_managed:children]\n"
+ "server01\n"
+ "server02\n\n"
+ "[notmanaged]\n"
+ "server04\n"
+ "server05\n\n"
+ "[ManagedMSSQLServer2016]\n"
+ "Server4\n"
+ "Server5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}