$re = '/^\[(?<group>.*)(?<!:children)\]/m';
$str = '[man-aged-sql:children]
ManagedMSSQLDBMS2016DBAMode
ManagedMSSQLServer2016
ManagedMSSQLServer2017
[all_managed:children]
server01
server02
[notmanaged]
server04
server05
[ManagedMSSQLServer2016]
Server4
Server5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);