import Foundation
let pattern = #"(?<![;\{\}]|\*\/|\s*\/{2}.*?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
let app = nothing;
/* main function */
if (something) {
// this will be the eroor
const error = "ough-ough!"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)