$re = '/(?<![;\{\}]|\*\/|\s*\/{2}.*?)$/m';
$str = 'let app = nothing;
/* main function */
if (something) {
// this will be the eroor
const error = "ough-ough!"
}';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;