import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![;\\{\\}]|\\*\\/|\\s*\\/{2}.*?)$";
final String string = "let app = nothing;\n"
+ "/* main function */\n"
+ "if (something) {\n"
+ " // this will be the eroor\n"
+ " const error = \"ough-ough!\"\n"
+ "}";
final String subst = ";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}