#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<![;\{\}]|\*\/|\s*\/{2}.*?)$"
Local $sString = "let app = nothing;" & @CRLF & _
"/* main function */" & @CRLF & _
"if (something) {" & @CRLF & _
" // this will be the eroor" & @CRLF & _
" const error = "ough-ough!"" & @CRLF & _
"}"
Local $sSubst = ";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)