re = /(?<![;\{\}]|\*\/|\s*\/{2}.*?)$/m
str = 'let app = nothing;
/* main function */
if (something) {
// this will be the eroor
const error = "ough-ough!"
}'
subst = ';'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result