using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![;\{\}]|\*\/|\s*\/{2}.*?)$";
string substitution = @";";
string input = @"let app = nothing;
/* main function */
if (something) {
// this will be the eroor
const error = ""ough-ough!""
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}