import Foundation
let pattern = #"KAFKA_TOPIC='{dbname}.(.*?)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
CREATE OR REPLACE STREAM {issuer}_str_lancamentos_contabeis WITH (KAFKA_TOPIC='{dbname}.dbo.LancamentosContabeis', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_contas WITH (KAFKA_TOPIC='{dbname}.dbo.Contas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_pessoas WITH (KAFKA_TOPIC='{dbname}.dbo.Pessoas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_status_conta WITH (KAFKA_TOPIC='{dbname}.dbo.StatusConta', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)