package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)KAFKA_TOPIC='{dbname}.(.*?)'`)
var str = `CREATE OR REPLACE STREAM {issuer}_str_lancamentos_contabeis WITH (KAFKA_TOPIC='{dbname}.dbo.LancamentosContabeis', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_contas WITH (KAFKA_TOPIC='{dbname}.dbo.Contas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_pessoas WITH (KAFKA_TOPIC='{dbname}.dbo.Pessoas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_status_conta WITH (KAFKA_TOPIC='{dbname}.dbo.StatusConta', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}