#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)KAFKA_TOPIC='{dbname}.(.*?)'"
Local $sString = "CREATE OR REPLACE STREAM {issuer}_str_lancamentos_contabeis WITH (KAFKA_TOPIC='{dbname}.dbo.LancamentosContabeis', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);" & @CRLF & _
"CREATE OR REPLACE STREAM {issuer}_str_contas WITH (KAFKA_TOPIC='{dbname}.dbo.Contas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);" & @CRLF & _
"CREATE OR REPLACE STREAM {issuer}_str_pessoas WITH (KAFKA_TOPIC='{dbname}.dbo.Pessoas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);" & @CRLF & _
"CREATE OR REPLACE STREAM {issuer}_str_status_conta WITH (KAFKA_TOPIC='{dbname}.dbo.StatusConta', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")