# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"KAFKA_TOPIC='{dbname}.(.*?)'"
test_str = ("CREATE OR REPLACE STREAM {issuer}_str_lancamentos_contabeis WITH (KAFKA_TOPIC='{dbname}.dbo.LancamentosContabeis', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);\n"
"CREATE OR REPLACE STREAM {issuer}_str_contas WITH (KAFKA_TOPIC='{dbname}.dbo.Contas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);\n"
"CREATE OR REPLACE STREAM {issuer}_str_pessoas WITH (KAFKA_TOPIC='{dbname}.dbo.Pessoas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);\n"
"CREATE OR REPLACE STREAM {issuer}_str_status_conta WITH (KAFKA_TOPIC='{dbname}.dbo.StatusConta', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.