using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"KAFKA_TOPIC='{dbname}.(.*?)'";
string input = @"CREATE OR REPLACE STREAM {issuer}_str_lancamentos_contabeis WITH (KAFKA_TOPIC='{dbname}.dbo.LancamentosContabeis', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_contas WITH (KAFKA_TOPIC='{dbname}.dbo.Contas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_pessoas WITH (KAFKA_TOPIC='{dbname}.dbo.Pessoas', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
CREATE OR REPLACE STREAM {issuer}_str_status_conta WITH (KAFKA_TOPIC='{dbname}.dbo.StatusConta', VALUE_FORMAT='AVRO', PARTITIONS=#{KAFKA_TOPICS_PARTITIONS}#, REPLICAS=#{KAFKA_TOPICS_REPLICAS}#);
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}