import Foundation
let pattern = #"(?<=DASH_)[0-9]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"audio"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}