use strict;
my $str = 'https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback';
my $regex = qr/(?<=DASH_)[0-9]*/p;
my $subst = 'audio';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";