const regex = /(?<=DASH_)[0-9]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=DASH_)[0-9]*', '')
const str = `https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback`;
const subst = `audio`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);