# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=DASH_)[0-9]*/audio/;t' <<< "https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback"