using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=DASH_)[0-9]*";
string substitution = @"audio";
string input = @"https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}