// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$").unwrap();
let string = "312.876.9354
901-402-3541
(931)123-0953
(615) 561-0783
+17084223141";
let substitution = "$1 $2 $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}