import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+1)?\\(?([2-9]{0,1}[0-9]{2})\\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$";
final String string = "312.876.9354\n"
+ "901-402-3541\n"
+ "(931)123-0953\n"
+ "(615) 561-0783\n"
+ "+17084223141";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}