# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$/$1 $2 $3/mg;t' <<< "312.876.9354
901-402-3541
(931)123-0953
(615) 561-0783
+17084223141"