const regex = /^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+1)?\\(?([2-9]{0,1}[0-9]{2})\\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$', 'mg')
const str = `312.876.9354
901-402-3541
(931)123-0953
(615) 561-0783
+17084223141`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);