package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$`)
var str = `312.876.9354
901-402-3541
(931)123-0953
(615) 561-0783
+17084223141`
var substitution = "$1 $2 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}