$re = '/^(?:\+1)?\(?([2-9]{0,1}[0-9]{2})\)?[. -]?([0-9]{3})[.-]?([0-9]{4})$/m';
$str = '312.876.9354
901-402-3541
(931)123-0953
(615) 561-0783
+17084223141';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;