import Foundation
let pattern = #".+(\\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"C:\Users\Gary\Music\iTunes\iTunes Media\Music\Bielefelder Kinderchor\Stille Nacht, Heilige Nacht\04 Vom Himmel hoch, O Englein, kommt.mp3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)