$re = '/.+(\\\\)/';
$str = 'C:\\Users\\Gary\\Music\\iTunes\\iTunes Media\\Music\\Bielefelder Kinderchor\\Stille Nacht, Heilige Nacht\\04 Vom Himmel hoch, O Englein, kommt.mp3';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;