# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+(\\)/\1/g;t' <<< "C:\Users\Gary\Music\iTunes\iTunes Media\Music\Bielefelder Kinderchor\Stille Nacht, Heilige Nacht\04 Vom Himmel hoch, O Englein, kommt.mp3"