use strict;
my $str = 'C:\\Users\\Gary\\Music\\iTunes\\iTunes Media\\Music\\Bielefelder Kinderchor\\Stille Nacht, Heilige Nacht\\04 Vom Himmel hoch, O Englein, kommt.mp3';
my $regex = qr/.+(\\)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";