import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(\\\\)";
final String string = "C:\\Users\\Gary\\Music\\iTunes\\iTunes Media\\Music\\Bielefelder Kinderchor\\Stille Nacht, Heilige Nacht\\04 Vom Himmel hoch, O Englein, kommt.mp3";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}