package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+(\\)`)
var str = `C:\Users\Gary\Music\iTunes\iTunes Media\Music\Bielefelder Kinderchor\Stille Nacht, Heilige Nacht\04 Vom Himmel hoch, O Englein, kommt.mp3`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}