// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([CTLS][1-9]+)\s(Wurzel[\w]*))").unwrap();
let string = "Es zeigt sich eine T12 Wurzeleinenung links ohne Affektion der L4 Wurzel rechts";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}