re = /(([CTLS][1-9]+)\s(Wurzel[\w]*))/m
str = 'Es zeigt sich eine T12 Wurzeleinenung links ohne Affektion der L4 Wurzel rechts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end