$re = '`(([CTLS][1-9]+)\s(Wurzel[\w]*))`m';
$str = 'Es zeigt sich eine T12 Wurzeleinenung links ohne Affektion der L4 Wurzel rechts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);