const regex = new RegExp('(([CTLS][1-9]+)\\s(Wurzel[\\w]*))', 'gm')
const str = `Es zeigt sich eine T12 Wurzeleinenung links ohne Affektion der L4 Wurzel rechts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}