// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d*[a-zA-Z_]+\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*").unwrap();
let string = "#078 #Aptannua23 #12adasd #wefwdf asdasd #234sdf23sef23we #we345ewer435
#234se234wer #234wer234wer234wer234wer234wer234wer234wer234wer #wew #w #w3423 #243234234234234 #1 # 34234234234 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}