import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*[a-zA-Z_]+\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*";
final String string = "#078 #Aptannua23 #12adasd #wefwdf asdasd #234sdf23sef23we #we345ewer435\n"
+ "#234se234wer #234wer234wer234wer234wer234wer234wer234wer234wer #wew #w #w3423 #243234234234234 #1 # 34234234234 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}