const regex = /\d*[a-zA-Z_]+\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*[a-zA-Z_]+\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*[a-zA-Z_]*\\d*', 'g')
const str = `#078 #Aptannua23 #12adasd #wefwdf asdasd #234sdf23sef23we #we345ewer435
#234se234wer #234wer234wer234wer234wer234wer234wer234wer234wer #wew #w #w3423 #243234234234234 #1 # 34234234234 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}