re = /\d*[a-zA-Z_]+\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*[a-zA-Z_]*\d*/
str = '#078 #Aptannua23 #12adasd #wefwdf asdasd #234sdf23sef23we #we345ewer435
#234se234wer #234wer234wer234wer234wer234wer234wer234wer234wer #wew #w #w3423 #243234234234234 #1 # 34234234234 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end