import Foundation
let pattern = #"(\w+[A-Z]\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MiguelGarcia
JohnDoe
Jan Smit
Jansen
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)