$re = '/(\w+[A-Z]\w+)/';
$str = 'MiguelGarcia
JohnDoe
Jan Smit
Jansen
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;