# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+[A-Z]\w+)//g;t' <<< "MiguelGarcia
JohnDoe
Jan Smit
Jansen
"