re = /(\w+[A-Z]\w+)/
str = 'MiguelGarcia
JohnDoe
Jan Smit
Jansen
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result