#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w+[A-Z]\w+)"
Local $sString = "MiguelGarcia" & @CRLF & _
"JohnDoe" & @CRLF & _
"Jan Smit" & @CRLF & _
"Jansen" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)