using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+[A-Z]\w+)";
string substitution = @"";
string input = @"MiguelGarcia
JohnDoe
Jan Smit
Jansen
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}