// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[class\*=(?:"|')?(.*?)(?:"|')?\]"#).unwrap();
let string = "/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*=\"container\"] {}
/* Multiple classes */
[class*=\"container\"][class*=\"container-large\"] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class=\"container\"] {}
/* With ^= (begins with) */
[class^=\"container\"] {}
/* With $= (ends with) */
[class$=\"container\"] {}";
let substitution = ".$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}