#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[class\*=(?:"|')?(.*?)(?:"|')?\]"
Local $sString = "/***********************" & @CRLF & _
"***** SHOULD MATCH *****" & @CRLF & _
"***********************/" & @CRLF & _
"" & @CRLF & _
"/* No quotes */" & @CRLF & _
"[class*=container] {}" & @CRLF & _
"" & @CRLF & _
"/* Single quotes */" & @CRLF & _
"[class*='container'] {}" & @CRLF & _
"" & @CRLF & _
"/* Double quotes */" & @CRLF & _
"[class*="container"] {}" & @CRLF & _
"" & @CRLF & _
"/* Multiple classes */" & @CRLF & _
"[class*="container"][class*="container-large"] {}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/**************************" & @CRLF & _
"***** SHOULDN'T MATCH *****" & @CRLF & _
"**************************/" & @CRLF & _
"" & @CRLF & _
"/* With = (exactly equal) */" & @CRLF & _
"[class="container"] {}" & @CRLF & _
"" & @CRLF & _
"/* With ^= (begins with) */" & @CRLF & _
"[class^="container"] {}" & @CRLF & _
"" & @CRLF & _
"/* With $= (ends with) */" & @CRLF & _
"[class$="container"] {}"
Local $sSubst = ".$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)