$re = '/\[class\*=(?:"|\')?(.*?)(?:"|\')?\]/';
$str = '/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*=\'container\'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN\'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With $= (ends with) */
[class$="container"] {}';
$subst = ".$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;